Results 1 to 4 of 4

Thread: Can't pedal my v34

  1. #1
    Skyline Owners Club Registered User Beejay's Avatar
    Join Date
    Oct 2007
    Posts
    25
    Images
    4

    Can't pedal my v34

    Hello interested persons.

    I just wondered if anyone could shed any light on my Skyline 350GT problem:
    When happily driving along, the engine seemed to suddenly die, but it didn't completely cut out, just went on to tickover only. The throttle pedal being depressed did very little. I soon realised it has an electronic throttle and something had gone down. After managing to get the car to the pub car park 500 yards away on tickover only, I went in and phoned the RAC. Several pints later, they answered and I managed to persuade them to attend sooner than 2 hours. The RAC technician went through several tests, then tried to communicate with the car through the OBD socket. After telling him to try Nissan 350z, he got 4 codes all pointing to the throttle pedal sensor, relay or actuator. He pulled a few pipes which raised the revs to about 2000 and he followed me home, which was about 4 miles.
    I tested the Pedal Sensor resistance, which seemed fine, but I ordered on from China as it was only 10 and I ordered a used Throttle actuator from the USA. I fitted the actuator with the original pedal sensor and ....no difference. So I fitted the new sensor as well, and still no difference.
    I know the relay is working, so can anyone tell me what I'm missing please?

  2. #2
    Skyline Enthusiast Registered User Richf's Avatar
    Join Date
    Jan 2007
    Location
    UK
    Posts
    5,658
    Have you tried the "pedal dance" / I know the 350z can throw weird issues until fully cleared and new pedals need to be "calibrated"

    https://www.350z-uk.com/topic/53148-...-valve-resets/

  3. #3
    Skyline Owners Club Registered User Beejay's Avatar
    Join Date
    Oct 2007
    Posts
    25
    Images
    4
    Quote Originally Posted by Richf View Post
    Have you tried the "pedal dance" / I know the 350z can throw weird issues until fully cleared and new pedals need to be "calibrated"

    https://www.350z-uk.com/topic/53148-...-valve-resets/
    Hi Rich.
    Yes I have tried the "Pedal Dance" several times, but the CEL didn't ever blink. I've printed those instructions off so that I can check them against those I've already tried and I'll give it another go, if different.

    Cheers.

  4. #4
    Skyline Enthusiast Registered User skyline alan's Avatar
    Join Date
    Dec 2009
    Location
    Westleigh, Tiverton
    Posts
    4,128
    may pay to ask on the v35/v36 page on facebook
    Tsunami R32 http://www.skyline-owners-club.com/f...ad.php?t=38641 ITS ALL ABOUT THE CHICKENEY CHICKEN

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •